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4.  Managing Subcontract Information

This chapter contains information to help the prime contractor on a state transportation
department project exchange contract and vendor information with the State Highway
Agency (SHA).  Contractors will use the SubCon program to enter subcontract
information, including subcontract vendors, items, item quantities, and item prices,
generate reports, and submit the modified contract information back to the SHA.

4.1  Installing SubCon from Floppy Install Disks
Follow these steps to install the Expedite SubCon application software from the floppy
disk you received from the SHA:

1. Insert the Install Disk into your floppy drive.

2. The Installation window appears.  Click the INSTALL button.

3. The Expedite SubCon Setup program will begin.  Follow the instructions
given in the setup program.

4.2  Starting SubCon
You must be running Windows to start the SubCon program.  To open the SubCon
program, double-click on the SubCon icon.
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Figure 4-1.  SubCon Icon

SubCon opens the main SubCon window, displaying two empty panes.

Figure 4-2.  Expedite SubCon Window

SubCon
Icon
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 4.3  Using Buttons and Menus to Invoke Commands
 Most SubCon windows have title bars, menu bars, and button bars so you can easily
activate commands.

  

 Figure 4-3.  Typical SubCon Title, Menu, Button and Des Header Bars

 4.3.1  Title Bar

 The title bar contains the name of the application or window and buttons you can click to
size, move, and close the window.  In Windows, you can access the Control menu by
clicking an icon in the upper-left corner of the window that represents the application in
which you are working.  In SubCon this icon will look like a small yellow triangle
enclosing the letters SUB.

 An easier way to manipulate the window is to use the three buttons in the upper-right
corner of the window.  The X button closes the application completely, the middle button
either reduces the size of the window to its intermediate size or maximizes the window
from its intermediate size, and the _ button minimizes the application and displays it on
the Windows taskbar.

 4.3.2  Menu Bar

 The menu bar (which includes the File, Edit, Tools, View, and Help menus) contains the
names of menus of commands.  Dimmed (grayed) menus are not available for the active
window.  You can click on a menu name to display all available commands for that menu
and then click on the command to activate it.

Title Bar

Menu Bar

Button Bar



4-4 Managing Subcontract Information

 Below the menu bar is the button bar, which contains buttons for some of the most useful
commands from the menus.  The buttons available on this bar depend on the window that
is open.  In other words, the button bar is context specific.

 Select SubCon commands in one of these ways:

 Click on the menu name to display the menu items available from that menu.
From there, select the command you want to run.  For example, you could
select Open from the File menu,

 Click on one of the buttons on the button bar to begin working with one of the
major groups of data.  For example, you could click on the OPEN CONTRACT
button and SubCon would display the Open Proposal window.

4.4  Opening a Contract File
To open a contract file, select Open from the File menu.  SubCon displays the Open
Contract window.

Figure 4-4.  Open Contract Window

Browse to the directory where the contract data file you want to import is located.  Select
the file you want to import and click the OPEN button.
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Figure 4-5.  Contract Data Files

SubCon displays the main window with the contract identified in the title bar.  The left
pane of the window displays a tree view of the contract information and the right pane
displays general information about the contract.

Figure 4-6.  Contract Window

You can adjust the width of the panes by placing the cursor over the border between the
two panes until the cursor turns into a line with arrows on each end.  Press the left mouse
button and drag left or right to adjust the width of the panes.  The panes maintain these
new widths until you change them again.

When a contract is first opened, the contract folder is displayed in the left pane of the
contract window, but the folder is closed.  To the left of the folder icon is a plus box [+].
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Click on the plus box [+] to expand the tree view hierarchy for that contract.  Notice that
the plus box [+] has changed to a minus box [-].  You can collapse the tree view again by
clicking the minus box [-].

Clicking on any folder in the hierarchy will open that folder and display related
information in the right pane of the contract window. The tree view contains a folder for
each subcontractor in the contract, including nested subcontractors.

Each subcontractor folder has a corresponding Items folder containing a list of all the
contract items assigned to that subcontractor, if that subcontractor uses subcontract items.

Figure 4-7.  SubCon Extended Tree View

The folders in the tree view are color coded:  a green folder indicates that it contains
valid, error-free information;  a yellow folder indicates that it contains information with
warnings; and a red folder contains information with errors.

4.5  Managing Subcontract Information
You can add, change and delete subcontract information in the Contract window.

4.5.1  Adding Subcontract Information

To add a subcontractor to the contract, click on the contract folder in the tree view and
select Add Subcontractor from the Edit menu.  You can also add a subcontractor by
clicking on the Subcontractors folder and selecting Add Subcontractor from the right
mouse button menu.
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SubCon adds a new folder to the list of subcontractors for the contract in the left pane and
displays text boxes for adding new subcontract information in the right pane.

Figure 4-8.  New Subcontractor Folder in Tree View

To add the new subcontractor, enter the subcontractor’s name or click the down arrow to
display a list of registered vendors.  If you enter the first letters of a name that already
exists in the list, SubCon will automatically advance the list to that name.  Click on the
name to select it and SubCon enters information for that vendor into the remaining text
boxes.  You can also select a vendor by entering the vendor’s ID number in the ID text
box, or the vendor’s address in the Address text box.  If the name of the new vendor is
not in the list, type the name in the Name text box and press TAB to move to the next text
box.  In the left pane, SubCon adds the vendor’s name to the new subcontractor folder.

Complete the subcontractor record by entering information into these remaining fields:

Sub Type This field contains a list of valid codes for subcontractor
classifications.  Certain sub types require that a subcontract amount be
used instead of contract items to calculate the bid.  When these sub
types are chosen, you must also enter an amount in the Subcontract
Amount field to create a complete record.

Type of Work This field contains a list of valid codes for work classifications.  The
choices available depend on the selected subcontractor.

Notes Miscellaneous comments may be added to the record in this field.
These are not used in processing.

Select Save from the File menu to save the new subcontractor record.
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Depending on how the option is set in the SubGen configuration file, you may be able to
add nested subcontractors to the contract.  SubCon adds a new subfolder in the left pane.
Follow the steps described above to complete the new subcontractor record.

If nested subcontractors are not allowed, all subcontractor folders appear at the same level
in the tree.

4.5.2  Changing Subcontract Information

To change information for a subcontractor, click on the subcontractor folder in the left
pane and in the right pane, edit the information in the text boxes.  Select Save from the
File menu to save your work.

 Note:  Depending on an option in the SubGen configuration file, you may not
be able to change information for subcontractor records that were imported
from SiteManager.

4.5.3  Deleting Subcontract Information

To delete a subcontractor from the list of subcontractors for this contract, select the
subcontractor folder in the left pane and choose Delete Subcontractor from the Edit
menu or the right mouse button menu.  SubCon displays a Delete Confirmation window.

Click YES to complete the delete or NO to return to the window without deleting the
subcontractor.  Select Save from the File menu to save your work.

 Note:  Depending on an option in the SubGen configuration file, you may not
be able to delete a subcontractor record that was imported from
SiteManager.

4.6  Managing Subcontract Items, Item Quantities, and
Prices
When you have finished adding a new subcontractor to the contract, you can now begin to
define the items on which that vendor will work.  To assign items to a subcontractor,
click on the Subcontractor Items folder for that subcontractor.

 Note:  If the subcontractor is of a sub type that does not use items, SubCon
will not create an Items folder for that subcontractor.  For these
subcontractors, you must instead enter an amount in the Subcontract
Amount field.
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Figure 4-9. Subcontractor Items Folder

SubCon displays the Subcontractor Items window.

Figure 4-10.  Subcontractor Items Window

The window is divided into two sections:

 The upper section of the window contains a scrollable list of all the items that
can be subcontracted.  The list is organized by section and line numbers.  The
items that are not assigned to the selected subcontractor appear dimmed.

Subcontractor
Items Folder
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 The lower section of the window contains information about the item
currently selected in the list.  You can add, change, or delete the quantity, unit
price, and total cost information for the selected item.  You can also add
miscellaneous information in the Note field.

To subcontract an item to a vendor, select the item from the list in the upper section of the
Subcontractor Item window, and either click the check box in the Use? column in the
upper section of the window or the check box labeled Subcontract this item to this
vendor in the lower section of the window.

 

Figure 4-11.  Check Box for Subcontracting Line Items

To delete an item, select the item in the upper section of the window and clear either the
Use? check box or the Subcontract this item to this vendor check box.

 Note:  You cannot delete a subcontract item record that was created in
SiteManager and imported into SubCon.

When you select an item in the upper section of the window, SubCon displays
information about the selected item in the lower half of the window.  You can add,
change and delete information in these fields:

Quantity SubCon calculates the quantity for the item as the remaining quantity
not already assigned to other subcontractors.  Partial items are not
included in this calculation.  You can change the quantity by clicking
in the Quantity field and editing the value.

Unit Price SubCon displays the awarded contract item unit price in the Unit Price
field, but you can change this value at any time.  If you change the
unit price, SubCon recalculates the Total by multiplying the new unit
price by the quantity.

Subcontract
this item to
this vendor
check box

Use? check
box
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Total SubCon automatically calculates the extended amount shown in the
Total field as the product of the quantity and the unit price.  You can
also change this value, in which case SubCon will recalculate the
quantity by dividing the new extended amount by the unit price. If the
extended amount for a subcontract item exceeds the extended amount
for the contract item, SubCon displays a warning message.

 Note:  You can use math formulas to enter information in any numeric field.
The formula evaluates immediately when you leave the field and is not
stored.

When you have finished entering information for the item, select Save from the File
menu to save your work.  SubCon automatically checks to make sure you have entered
information for all of the item’s required fields, and displays an error message if any
information is missing.

Depending on the options that have been selected in your SubGen configuration file, and
whether the item record was created in SubCon or imported from SiteManager, SubCon
may also perform these checks on the item quantities you have entered:

 A check to make sure you have not entered an item quantity that exceeds the
contract item quantity.

 A check to make sure the quantity you entered does not fall below the amount
that was assigned in SiteManager.

 If the subcontractor does not use items, a check to make sure the subcontractor
amount does not fall below the amount assigned in SiteManager.

SubCon displays an error message if any of these quantity checks fail.

4.6.1  Using Partial Items

Partial items are items that are not constrained by SubCon’s usual quantity checks and
whose quantities are not included in determining minimums and maximums.  An item
may be designated as a partial item when the total quantity for that item is assigned to
more than one subcontractor, thereby avoiding what SubCon would otherwise identify as
a quantity error.

As an example, suppose one of the items in a contract is 2,000 pounds of asphalt.  Two
subcontractors are being used, one to supply the asphalt and the other to deliver it to the
construction site.  You can resolve this situation in one of these two ways:

 By designating the item as a partial item and assigning the total quantity of
2,000 pounds of asphalt to both of the subcontractors.  This will not cause an
error because SubCon will not include this item in its quantity checks.
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 By assigning a quantity of 1,000 pounds to each of the subcontractors.  In this
case, do not designate the item as a partial item.

To designate an item as a partial item, select the item in the Subcontractor Items window
and click the Partial Item check box in the detail area of the window.

Figure 4-12.  Partial Items Check Box

 Note:  You cannot designate a subcontract item that was created in
SiteManager and imported into SubCon as a partial item.

4.7  Printing a Schedule of Items Report
The Schedule of Items report is a listing of all the items you have subcontracted to a
particular vendor.  Follow these steps to print this report for a vendor:

1. In the left pane of the Subcontractor Items window, select the Subcontractor
folder for the vendor.

2. Section Print from the File menu.  If any errors exist in the subcontractor
record, SubCon displays a Contract Error window.

3. SubCon displays a Print Option window.  Select printing parameters and click
OK.

Partial
Item
Check Box
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4.8  Using SubCon Options
You have several options available to you for SubCon.  To set SubCon options, select
Options from the Tools menu.  SubCon displays a SubCon Options window.

Figure 4-13.  SubCon Options Window

The window displays options in four groups of checkboxes.  When you have finished
selecting options, click the APPLY button to immediately apply your choices and OK to
close the Options window or click CANCEL to close the window without saving your
changes.
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